Internet Explorer no puede mostrar la página de apache con un único host SSL virtual

Tengo una pregunta que ha surgido de alguna manera en diferentes preguntas, pero todavía no puedo encontrar la solución, todavía.

Mi problema es que estoy hospedando un sitio en apache 2.4 en debian con SSL e Internet Explorer 7 en Windows XP muestra

Internet Explorer cannot display the webpage 

Sólo tengo un host virtual que utiliza ssl, pero DIFERENTES anfitriones virtuales que utilizan http. Aquí está mi configuration para el sitio con SSL habilitado (etc / sites-avaible / default-ssl no está vinculado)

 <Virtualhost xx.yyy.86.193:443> ServerName www.my-certified-domain.de ServerAlias my-certified-domain.de DocumentRoot "/var/local/www/my-certified-domain.de/current/www" Alias /files "/var/local/www/my-certified-domain.de/current/files" CustomLog /var/log/apache2/access.my-certified-domain.de.log combined <Directory "/var/local/www/my-certified-domain.de/current/www"> AllowOverride All </Directory> SSLEngine on SSLCertificateFile /etc/ssl/certs/www.my-certified-domain.de.crt SSLCertificateKeyFile /etc/ssl/private/www.my-certified-domain.de.key SSLCipherSuite HIGH:MEDIUM:!aNULL:+SHA1:+MD5:+HIGH:+MEDIUM SSLCertificateChainFile /etc/apache2/ssl.crt/www.my-certified-domain.de.ca BrowserMatch "MSIE [2-8]" nokeepalive downgrade-1.0 force-response-1.0 </VirtualHost> <VirtualHost *:80> ServerName www.my-certified-domain.de ServerAlias my-certified-domain.de CustomLog /var/log/apache2/access.my-certified-domain.de.log combined Redirect permanent / https://www.my-certified-domain.de/ </VirtualHost> 

my ports.conf se parece a esto:

 NameVirtualHost *:80 Listen 80 <IfModule mod_ssl.c> # If you add NameVirtualHost *:443 here, you will also have to change # the VirtualHost statement in /etc/apache2/sites-available/default-ssl # to <VirtualHost *:443> # Server Name Indication for SSL named virtual hosts is currently not # supported by MSIE on Windows XP. Listen 443 </IfModule> <IfModule mod_gnutls.c> Listen 443 </IfModule> 

la salida de apache2ctl -S es así:

 xx.yyy.86.193:443 www.my-certified-domain.de (/etc/apache2/sites-enabled/020-my-certified-domain.de:1) wildcard NameVirtualHosts and _default_ servers: *:80 is a NameVirtualHost default server phpmyadmin.my-certified-domain.de (/etc/apache2/conf.d/phpmyadmin.conf:3) port 80 namevhost phpmyadmin.my-certified-domain.de (/etc/apache2/conf.d/phpmyadmin.conf:3) port 80 namevhost staging.my-certified-domain.de (/etc/apache2/sites-enabled/010-staging.my-certified-domain.de:1) port 80 namevhost testing.my-certified-domain.de (/etc/apache2/sites-enabled/015-testing.my-certified-domain.de:1) port 80 namevhost www.my-certified-domain.de (/etc/apache2/sites-enabled/020-my-certified-domain.de:31) 

He incluido la solución para esta pregunta: Internet Explorer no puede mostrar la página, otros browseres pueden, posiblemente, htaccess / server de error

Y entiendo la respuesta de esta pregunta:

Cómo configurar Apache NameVirtualHost en SSL?

En fakt: Sólo tengo un certificate ssl para el dominio. Y sólo quiero ejecutar un host virtual con ssl. Así que sólo quiero usar el ip para el host virtual ssl. Pero aún así (después de reiniciar / reiniciar / probar) Internet Explorer todavía no mostrará la página.

Cuando interpreto el apachectl -S, también, ya tengo sólo un host SSL y esto debería responder a la inicial de SSH apretón de manos, ¿no?

¿Qué hay de malo en esta configuration?

Muchas gracias Philipp

Actualización: funciona en todos los demás browseres. He depurado con wireshark y el server envía una alerta para notificar que la connection está cerrada. Pero no puedo ver el problema en los loggings

¿Funciona en otros browseres, por ejemplo Firefox en WinXP, IE7 en Vista / 7/8, IE8 +, iOS, Android?

En caso afirmativo, sospecha que su suite de encryption podría ser demasiado restrictiva / moderna para permitir IE7 / XP. O forzar a su base de usuarios para actualizar su browser / sistema operativo o reconfigurar su SSLCipherSuite:

Consulte https://github.com/client9/sslassert/wiki/IE-Supported-Cipher-Suites

También vea este posible hotfix WinXP / KB: http://support.microsoft.com/kb/2541763/en-us

Tal vez intente:

 SSLCipherSuite ECDHE-RSA-AES256-GCM-SHA384:ECDHE-RSA-AES128-GCM-SHA256:DHE-RSA-AES256-GCM-SHA384:DHE-RSA-AES128-GCM-SHA256:ECDHE-RSA-AES256-SHA384:ECDHE-RSA-AES128-SHA256:ECDHE-RSA-AES256-SHA:ECDHE-RSA-AES128-SHA:DHE-RSA-AES256-SHA256:DHE-RSA-AES128-SHA256:DHE-RSA-AES256-SHA:DHE-RSA-AES128-SHA:ECDHE-RSA-DES-CBC3-SHA:EDH-RSA-DES-CBC3-SHA:AES256-GCM-SHA384:AES128-GCM-SHA256:AES256-SHA256:AES128-SHA256:AES256-SHA:AES128-SHA:DES-CBC3-SHA:HIGH:!aNULL:!eNULL:!EXPORT:!CAMELLIA:!DES:!MD5:!PSK:!RC4 

(encontrado lo anterior en https://raymii.org/s/tutorials/Strong_SSL_Security_On_Apache2.html )