sudo yum install httpd está lanzando errores

Hola, este es el command im escribiendo y su devolver el error que vea, cualquier sugerencia por favor

[ec2-user@ip-172-31-41-46 ~]$ sudo yum install httpd Loaded plugins: priorities, update-motd, upgrade-helper Resolving Dependencies --> Running transaction check ---> Package httpd.x86_64 0:2.2.27-1.3.amzn1 will be installed --> Processing Dependency: httpd-tools = 2.2.27-1.3.amzn1 for package: httpd-2.2.27-1.3.amzn1.x86_64 --> Running transaction check ---> Package httpd-tools.x86_64 0:2.2.27-1.3.amzn1 will be installed --> Processing Conflict: httpd24-2.4.10-1.59.amzn1.x86_64 conflicts httpd < 2.4.10 --> Processing Conflict: httpd24-tools-2.4.10-1.59.amzn1.x86_64 conflicts httpd-tools < 2.4.10 --> Finished Dependency Resolution Error: httpd24-tools conflicts with httpd-tools-2.2.27-1.3.amzn1.x86_64 Error: httpd24 conflicts with httpd-2.2.27-1.3.amzn1.x86_64 You could try using --skip-broken to work around the problem You could try running: rpm -Va --nofiles --nodigest [ec2-user@ip-172-31-41-46 ~]$ 

cuando hago yum install –skip-broken httpd devuelve:

 Packages skipped because of dependency problems: httpd-2.2.27-1.3.amzn1.x86_64 from amzn-updates httpd-tools-2.2.27-1.3.amzn1.x86_64 from amzn-updates httpd-2.2.27-1.3.amzn1.x86_64 de amzn-updates Packages skipped because of dependency problems: httpd-2.2.27-1.3.amzn1.x86_64 from amzn-updates httpd-tools-2.2.27-1.3.amzn1.x86_64 from amzn-updates 

Está intentando instalar el package httpd , que contiene la versión 2.2 de Apache, pero ya tiene httpd24 , que contiene la versión 2.4 de Apache.

Antes de hacer cualquier otra cosa, primero decida qué versión desea.