El cuadro inestable de Debian tiene la versión antigua de un package, se niega a actualizar, rompe una installation

Necesito instalar python-twisted, así que …

$ sudo aptitude install python-twisted [[...]] The following packages have unmet dependencies: python-twisted-mail: Depends: python-twisted-core (>= 10.1) but 10.0.0-3 is to be installed. python-twisted-news: Depends: python-twisted-core (>= 10.1) but 10.0.0-3 is to be installed. python-twisted-words: Depends: python-twisted-core (>= 10.1) but 10.0.0-3 is to be installed. python-twisted-names: Depends: python-twisted-core (>= 10.1) but 10.0.0-3 is to be installed. The following actions will resolve these dependencies: [[...]] 

Oh. Así que no va a instalar python-twisted, porque depende de … hey, espere un segundo … Vamos a comprobar algo … http://packages.debian.org/sid/python-twisted-core dice que la última versión es 10.1.0-1 …

 $ sudo aptitude update [[...]] $ aptitude show python-twisted-core Package: python-twisted-core New: yes State: not installed Version: 10.0.0-3 Priority: optional [[...]] $ apt-cache policy python-twisted-core python-twisted-core: Installed: (none) Candidate: 10.0.0-3 Version table: 10.0.0-3 0 500 http://ftp.us.debian.org unstable/main Packages 

Huh. Así que la aptitud, por alguna razón, todavía piensa que 10.0.0-3 es la última versión. Lo cual no es. ¿Por qué? ¿Estoy en algún espejo de mierda, o es porque de repositorys rogue?

 $ cat /etc/apt/sources.list deb http://ftp.us.debian.org/debian/ unstable main contrib non-free deb-src http://ftp.us.debian.org/debian/ unstable main contrib non-free 

Ok, así que estoy en el espejo principal de Debian, ha sido un día desde la actualización, por lo que cualquier latencia cron-debería-ser tratado por ahora … y todavía está roto. Incluso he probado lo anterior en una nueva installation de Debian Unstable, todavía con la misma melodía. Ahora oficialmente no tengo idea de qué hacer. Tal vez la gente de Server Fault puede ayudar.

Basado en la salida de la apt-cache policy python-twisted-core , apt no ve que existe la versión 10.1.0-1. Muestra la versión 10.0.0-3 como instalable de la fuente que usted espera.

Sólo por reference, el problema podría ser que se olvidó de ejecutar apt-get update (o algo equivalente, como aptitude update ), o que el command de actualización falló por alguna razón, como un error de networking. Pero no creo que eso sea lo que te pasó.

El problema podría ser que el espejo no está al día. Pero he comprobado, parece tener el mismo contenido que otros espejos.

No dices en qué architecture estás. Mi conjetura es que su architecture todavía no tiene la versión más nueva.

A menudo toma unos días para que aparezca un package en todas las architectures, ya que algunas architectures tienen más poder de cálculo para la construcción que otras. Aunque python-twisted-core es independiente de la architecture, su package de origen no lo es. Puede ver qué architectures tienen qué versiones mirando la página de un package dependiente de la architecture del mismo origen . Veo que a partir de hoy, i386 tiene 10.1.0-1 pero amd64 todavía tiene 10.0.0-3. python-twisted-mail es de un package diferente que se propagó rápidamente porque es dependiente de la architecture.

Este es el tipo de preocupación que la testing le protege contra. A less que realmente necesite la versión más reciente, hay una muy buena probabilidad de que agarrando todos sus packages python-retorcidos de la testing resolverá su problema. La forma más sencilla de hacerlo es agregar testings a su sources.list (ya que los packages de las testings son más antiguos que los packages de unstable, esto no debería cambiar lo que se instala, excepto si usted da una request explícita) y seleccionando manualmente el 10.0.0 -3 versiones en la interfaz interactiva de usuario de aptitude.

El problema real, detrás de las escenas, puede explicarse en el hilo de usuario debian relevante :

Gracias, ya veo. El problema es que el package fuente retorcido (que construye el package binary python-twisted) no se ha subido todavía en amd64, y aunque python-twisted es un package arch: all, se mantiene en la versión anterior.

Anteriormente, un package arch: all estaba sincronizado en todos los arcos, pero dado que a menudo se creaban desinstalaciones cuando foo (arch: any) dependía de foo-common (arch: all) de la misma fuente y foo Los ftp-maestros cambiaron eso.

En este caso, esto tiene el efecto secundario indeseable de que los packages de un package fuente diferente dependen de la nueva versión de python-twisted-core, haciéndolos desinstalables en amd64.

Así que sí. Como en la respuesta de Gilles, el problema era que el package no estaba construido para amd64, pero debido a que los bits del package principal eran independientes de la plataforma, se extraviaron en el shuffle. Creo. Pero, no es ninguna preocupación, sólo hacer la solución como se describe en la respuesta de Gilles, dar aviso de su problema a una de las lists de correo debian (como debian-usuario ), la esperanza de que un informe de error un poco desconcertante, y ser paciente. Esto también pasará. Especialmente en Sid.