Linux crea automáticamente particiones LVM en los miembros RAID?

He tenido una matriz RAID1 de software en producción durante más de un año que tiene particiones LVM encima de / dev / md0. Reinicié durante el fin de semana para aplicar algunos parches del kernel y ahora la matriz no se presentará. Obtenga el post "Continúe esperando o presione S para saltar el assembly o M para recuperación manual" en el arranque. Me golpeó M, inicio de session como root, y la matriz RAID es, pero ninguna de las particiones LVM están disponibles. Es como si todo hubiera desaparecido. Paré el arreglo y lo traje para arriba en un solo disco (es RAID1) con --run . Ok, el material lvm está ahí ahora. Así que agregué un nuevo disco y lo añadí a la matriz degradada. Comienza a rebuild. Hago un fdisk del nuevo disco que acabo de agregar y hay una nueva partición allí del tipo 'Linux LVM'. No agregué esa partición. ¿Que esta pasando? Ni siquiera estoy usando particiones, solo uso los dispositivos sin procesar.

La única forma en que podía get el arreglo de RAID de software era dejar LVM apagado y partición dura. He intentado usar ambos dispositivos crudos, así como las particiones tipo 0xFD y tan pronto como intenté usar LVM a través de / dev / md0, los types de partición cambiarían automáticamente de 0xFD a "LVM" en todos los miembros del raid. Muy, muy extraño. He estado usando LVM sobre Linux RAID de software durante casi una década y nunca he visto este problema antes. Estoy comprando una tarjeta de Areca.