Problemas para instalar php-devel en CentOS 6

Estoy tratando de instalar los controlleres mongo para PHP en CentosOS 6. Ejecutar "pecl install mongo" se queja de que "package php-devel es necesario".

Ejecutar "yum install php-devel" da el siguiente error:

Loaded plugins: fastestmirror, prest, priorities Loading mirror speeds from cached hostfile * base: mirrors.usc.edu * epel: mirrors.xmission.com * extras: centos.sonn.com * updates: mirror.hmc.edu Setting up Install Process Resolving Dependencies --> Running transaction check ---> Package php-devel.x86_64 0:5.3.3-14.el6_3 will be installed --> Processing Dependency: php = 5.3.3-14.el6_3 for package: php-devel-5.3.3-14.el6_3.x86_64 --> Processing Dependency: automake for package: php-devel-5.3.3-14.el6_3.x86_64 --> Processing Dependency: autoconf for package: php-devel-5.3.3-14.el6_3.x86_64 --> Running transaction check ---> Package autoconf.noarch 0:2.63-5.1.el6 will be installed ---> Package automake.noarch 0:1.11.1-1.2.el6 will be installed ---> Package php-devel.x86_64 0:5.3.3-14.el6_3 will be installed --> Processing Dependency: php = 5.3.3-14.el6_3 for package: php-devel-5.3.3-14.el6_3.x86_64 --> Finished Dependency Resolution Error: Package: php-devel-5.3.3-14.el6_3.x86_64 (updates) Requires: php = 5.3.3-14.el6_3 Installed: php-5.3.15-1.el6.remi.x86_64 (@remi) php = 5.3.15-1.el6.remi Available: php-5.3.3-3.el6_2.8.x86_64 (base) php = 5.3.3-3.el6_2.8 Available: php-5.3.3-14.el6_3.x86_64 (updates) php = 5.3.3-14.el6_3 You could try using --skip-broken to work around the problem You could try running: rpm -Va --nofiles --nodigest 

¿Alguna sugerencia? Parece que está intentando instalar devel para 5.3.3-14 en lugar de 5.3.3-15, pero no estoy seguro de cómo cambiar eso.

Parece que php-5.3.15-1.el6.remi.x86_64 fue instalado desde el repo remi , pero ese repo ya no está disponible o habilitado.

Prueba esto primero:

 yum --enablerepo=remi install php-devel 

Si confía en repos de terceros, debería poder habilitarlo con estos pasos:

 wget http://rpms.famillecollet.com/enterprise/remi-release-6.rpm sudo rpm -Uvh remi-release-6*.rpm epel-release-6*.rpm sudo vim /etc/yum.repos.d/remi.repo -> enabled=1 

Consulte http://www.rackspace.com/knowledge_center/article/installing-rhel-epel-repo-on-centos-5x-or-6x para get más detalles.

Parece que has actualizado PHP a 5.3.15 desde el repository REMI

 Installed: php-5.3.15-1.el6.remi.x86_64 (@remi) 

Sin embargo, parece que has eliminado el repository REMI de tus repos de yum, ya que no veo ningún espejo remi en la list. Sus repos activados actualmente no tienen la versión correcta de php-devel disponible. Tendrás que volver a agregar el repository REMI, y luego instalar la versión php-devel que coincida con la versión de PHP actualmente instalada desde allí. En su caso, necesitará php-devel-5.3.15.

Instrucciones de installation para REMI: http://blog.famillecollet.com/pages/Config-en

Repos CentOS adicionales: http://wiki.centos.org/AdditionalResources/Repositories/