Utilice Mikrotik como un conmutador y enrute las subnetworkinges a través de otro enrutador

Tengo la siguiente configuration de networking:

  • Comtrend 5813 FTTH Router, conectado a WAN, digamos en 192.168.50.x (siendo la dirección del enrutador .1) y un server DHCP activo, dando direcciones de .150 a .200
  • Mikrotik 951G-2HnD conectado al enrutador de Comtrend, con dirección .2

Esta configuration funciona para ethernet; Quiero decir, puedo conectar una computadora a Mikrotik y la máquina obtendrá su propia dirección IP y será capaz de navegar por Internet.

Necesito configurar 2 WLAN diferentes, cada una de ellas en diferentes subnetworkinges, 192.168.60.0/24 y 192.168.70.0/24 Para eso configuro 2 serveres DHCP diferentes en Mikrotik, asignados a cada AP Virtual, y con Mikrotiks como dirección. 2 en ambos (192.168.60.2 y 192.168.70.2).

Cuando conecto un dispositivo a esas WLANs consigo una IP correcta pero no puedo conseguir tráfico pasar a través del ranurador al Internet.

He intentado usar diferentes opciones de routing, pero parece que no domino la architecture de Mikrotik lo suficiente.

¿Puede alguien guiarme para hacer este trabajo?

¡Gracias!

Suena como usted puede necesitar configurar el cortafuego para pasar con el tráfico del NAT en el Mikrotik. Esto es "enmascaramiento".

Cuando habilita NAT, por defecto el Mikrotik no habilita el enmascaramiento y como resultado no pasará a través del tráfico establecido. Debe activar específicamente la regla Firewall. Un equivalente en IPTABLES sería la regla básica "permitir todo establecido".

/ip firewall nat add chain=srcnat action=masquerade out-interface=Public 

Donde Público es el nombre de la interfaz en su puerto WAN enfrentado (en su ejemplo con la IP 192.168.50.1).

Referencia: http://wiki.mikrotik.com/wiki/Manual:IP/Firewall/NAT

De forma pnetworkingeterminada, Mikrotik no tiene reglas de firewall y reenvía todo el tráfico (la política pnetworkingeterminada es aceptar).

El Mikrotik necesita saber dónde reenviar el tráfico de los clientes inalámbricos. Añada una ruta pnetworkingeterminada a través de su enrutador FTTH. Ejecute este command en el Mikrotik:

 /ip route add gateway=192.168.50.1 

El enrutador FTTH necesita saber cómo responder a las subnetworkinges IP del cliente inalámbrico para que pueda agregar routes estáticas en el enrutador FTTH a través de 192.168.50.2 (preferible).

  • 192.168.60.0/24 via 192.168.50.2
  • 192.168.70.0/24 via 192.168.50.2

Si la adición de routes estáticas al FTTH no es posible, puede decirle al Mikrotik a NAT los clientes inalámbricos para que el enrutador FTTH vea todo el tráfico originado como 192.168.50.2 (no es preferible, el NAT doble no es el ideal).

 /ip firewall nat add action=masquerade chain=srcnat out-interface=ether1 

Donde ether1 es el puerto que ha asignado la dirección 192.168.50.2. Sugerencia: / export de dirección IP